Transactions Halted
Incident Report for Flume
Resolved
This incident has been resolved.
Posted Sep 20, 2024 - 15:11 EDT
Investigating
We are aware of the issue and it's cause and are working to restore services.
Posted Sep 20, 2024 - 15:03 EDT
This incident affected: Relay.