AWS Lambda Degraded Service Impacting Flume Services
Incident Report for Flume
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 18:14 EDT
Update
We are continuing to monitor the status of AWS. We have generally observed recovery of impacted services.
Posted Jun 13, 2023 - 17:56 EDT
Update
AWS has provided updates stating that Cloud Services-Support Telephony issue is now resolved.
Details of their status updates for other services can be found at https://health.aws.amazon.com/health/status.
Posted Jun 13, 2023 - 17:12 EDT
Monitoring
AWS has provided updates stating that they continue to work to resolve the issue and are observing improvement in error rates. They have expanded the number of services impacted. Details of their status updates can be found at https://health.aws.amazon.com/health/status.

Flume continues to monitor the incident.
Posted Jun 13, 2023 - 16:46 EDT
Identified
AWS is reporting elevated error rates in their Lambda service which supports the phone and SFTP systems. During this time users may experience difficulty connecting to those services. AWS states that they have identified the cause and are implementing a fix.

Other core services such as the API and My.flumehealth.com (and variants) are unaffected by the degraded service.
Posted Jun 13, 2023 - 15:37 EDT
This incident affected: Health Administrator Services (sftp.flumehealth.com, Support Phone System).